Neue ipRec Version vom 22.10.2017

  • Hallo,


    ich habe eine neue ipRec Version für die

    DM500HD, DM800HD, DM800SE, DM8000, DM7020HD

    und die


    DM7080HD, DM820HD, DM900

    online gestellt.


    Seit der Umstellung von tvinfo von http auf https funktionierte mein Plugin nicht mehr. Die neue Version behebt das Problem.


    Viel Erfolg


    Aladin

  • Hallo Aladin,


    nach der installation der 4.17.2 erhalte ich die Fehlermeldung:


    root@dm7080:~$ dpkg -i /tmp/iprec*.deb

    Selecting previously unselected package iprec.

    (Reading database ... 14978 files and directories currently installed.)

    Preparing to unpack /tmp/iprec_4.17.2_all.deb ...

    Unpacking iprec (4.17.2) ...

    Setting up iprec (4.17.2) ...

    Traceback (most recent call last):

    File "/bin/iprec", line 4, in

    from xmltools import *

    ImportError: No module named xmltools

    Traceback (most recent call last):

    File "/bin/iprec", line 4, in

    from xmltools import *

    ImportError: No module named xmltools

    ************************************************************

    ********** Installation erfolgreich abgeschlossen **********

    ************************************************************



    Kannst du mir einenen Tip geben?

    Gruß

    aufdersuche

  • Hallo @hallo,


    In der ipRec Version für die

    DM500HD, DM800HD, DM800SE, DM8000, DM7020HD

    gibt es noch einen Programmfehler.


    Installiert die Pakete python-misc und python-textutils und iprec_4.16.24_all, dann sollte es gehen.

    Viele Grüße

    Aladin

  • Hallo aladin25,


    ich habe eine Frage, funktioniert das Plugin auch mit OpenATV 6.1 und einer Ultimo 4K?


    würde mich über eine Antwort sehr freuen.


    Vielen Dank.


    Liebe Grüße


    Gummistiefel

  • Hallo Gummistiefel ,


    mit OpenATV 6.1 muss nach der Installation des Plugins die Datei service.py aus der Datei Service_V2.zip für das OpenPLI Image in folgendes Verzeichnis kopiert und überschrieben werden:


    /usr/lib/enigma2/python/Plugins/Extensions/ipRecService


    Dann sollte es laufen.


    Viele Grüße


    Aladin

  • Hallo vielen Dank für die schnelle Antwort.

    Jetzt stehe grad etwas auf dem Schlauch woher bekomme ich diese Daten, die ich dort einfügen soll?

    Ich lade ja die ipk Datei installiere die soweit alles klar aber wo finde ich die zwei Daten die ich einfügen soll.


    Sorry für meine dumme Frage.


    Lg Gummistiefel.

  • Hallo Aladin25

    wenn ich versuche iprec in meiner Box zu installien bekomme ich folgende Meldung was kann ich tun?


    es ist eine DM8000:


    *****************************

    * http://www.newnigma2.to *

    *****************************

    * the next step is done *

    *****************************


    opendreambox 2.0.0 dm8000


    Die Dreambox ist aktuell und nichts verbogen.


    Wenn ich versuch iprec im Plugin Menu zu konfigurieren stürtz sie ab.


    Ich hatte die iprec v 22 drauf damitt ging aber TV info nicht meht.


    Herzliche Grüße und Danke für die Hilfe.





    root@dm8000:~# opkg install /media/hdd/iprec_4.16.24_all.ipk

    Installing iprec (4.16.24) to flash...

    Configuring iprec.

    ipRec jetzt konfigurieren [ja]:ja

    Traceback (most recent call last):

    File "/bin/iprec", line 130, in <module>

    AskForReturn(15)

    File "/bin/iprec", line 59, in __init__

    self.timeout()

    File "/bin/iprec", line 74, in timeout

    tsPath = sPath = GetSetupPath()

    File "/usr/lib/enigma2/python/Plugins/Extensions/ipRecService/xmltools.py", line 492, in GetSetupPath

    doc = OpenRoot()

    File "/usr/lib/enigma2/python/Plugins/Extensions/ipRecService/xmltools.py", line 542, in OpenRoot

    document = xml.etree.cElementTree.parse(filename)

    File "<string>", line 56, in parse

    File "<string>", line 35, in parse

    cElementTree.ParseError: not well-formed (invalid token): line 1, column 71

    Traceback (most recent call last):

    File "/bin/iprec", line 132, in <module>

    doc = OpenSetup()

    File "/usr/lib/enigma2/python/Plugins/Extensions/ipRecService/xmltools.py", line 552, in OpenSetup

    filename = GetSetupPath()

    File "/usr/lib/enigma2/python/Plugins/Extensions/ipRecService/xmltools.py", line 492, in GetSetupPath

    doc = OpenRoot()

    File "/usr/lib/enigma2/python/Plugins/Extensions/ipRecService/xmltools.py", line 542, in OpenRoot

    document = xml.etree.cElementTree.parse(filename)

    File "<string>", line 56, in parse

    File "<string>", line 35, in parse

    cElementTree.ParseError: not well-formed (invalid token): line 1, column 71

    ************************************************************

    ********** Installation erfolgreich abgeschlossen **********

    ************************************************************

    root@dm8000:~# opkg remove iprec

    Removing package iprec from flash...

    Clean

    *****************************************************************

    ********** Wiederherstellung erfolgreich abgeschlossen **********

    *****************************************************************

    root@dm8000:~#

  • Hallo aladin25 ,

    ich habe alles gelöscht und nochmal versucht, bei Aufruf des Plugins über das pluginmenü stürzt die Box ab.

    hier das Protokoll der Einrichtung und das crashlog der Boxenigma2_crash_1510575817.log.sent.txtenigma2_crash_1510575817.log.sent.txtenigma2_crash_1510575817.log.sent.txt:

    root@dm8000:~# opkg install /media/hdd/iprec_4.16.24_all.ipk

    Installing iprec (4.16.24) to flash...

    Clean

    Configuring iprec.

    ipRec jetzt konfigurieren [ja]:ja

    0: /media/EFRX68WT0N0

    1: /media/hdd

    Select the path of the configfiles by number [1] : 1

    Pfad der Setupdatei [/media/hdd/ipRecSetup.xml]:

    Pfad der Timerdatei [/media/hdd/ipRecTimer.xml]:

    TVTV-Service jetzt aktivieren [Ja]:ja

    Moechten sie fuer die Synchronisation das XML-Format aktivieren [Nein]:Nein

    TVTV Benutzername []:xxxxxxx

    TVTV Kennwort []:xxxxxx

    Sprache setzen []:de

    Zeit justieren [0]:0

    Traceback (most recent call last):

    File "/bin/iprec", line 130, in <module>

    AskForReturn(15)

    File "/bin/iprec", line 59, in __init__

    self.timeout()

    File "/bin/iprec", line 116, in timeout

    Hook(self.ConfigHook)

    File "/usr/lib/enigma2/python/Plugins/Extensions/ipRecService/xmltools.py", line 74, in Hook

    mod = __import__(modpath)

    File "/usr/lib/enigma2/python/Plugins/Extensions/ipRecService/Interfaces/tvinfo.py", line 6, in <module>

    import ssl

    File "/usr/lib/python2.7/ssl.py", line 58, in <module>

    import textwrap

    ImportError: No module named textwrap

    ************************************************************

    ********** Installation erfolgreich abgeschlossen **********

    ************************************************************

  • Hallo Aladin,


    ich finde deine App echt toll und bis zur der Umstellung bei TV Info lief auch alles sehr gut auf meiner DM7020HD und danach dann leider nicht mehr und ich hatte mir dann deine neue Version:


    iprec_4.16.24_all heruntergeladen und dann auch noch deine service 2 py installiert


    Leider stürzt meine DM7020HD jetzt auch immer ab wenn ich das Plugin von Dir starte.


    Ich habe mal mein CrashLog angehangen und hoffe du kannst mir weiterhelfen und wenn Du noch andere


    Danke Stefan

  • Hallo Aladin,


    danke für deine schnelle Antwort.


    Also ich habe das Image: Newnigma2 v4.0.1. 8201-60-61

    Enigma: 2016-06-16-tarball


    Die Datei "tvinfo.py" vom 14.10.2017 mit der Größe 7.033 liegt im dem Verzeichnis ab.


    Ich hatte auch schon versucht das ganze Plugin mit der Anweisung zu deinstallieren und dann neu zu installieren. Hat aber leider auch nichts gebracht.

    Stürzt immer noch ab sobald ich iprec aufrufe.


    Gruss Stefan

  • Hallo Aladin,


    ich habe vorhin das aktuelle Enigma Image:


    Newnigma2-daily 2017-11-24


    heruntergeladen und installiert.


    Danach habe ich versucht wieder iprec zu installieren nur leider kommt dann gleich beim installieren ein Problem:


    root@dm7020hd:~# opkg install /tmp/iprec_4.16.24_all.ipk

    Installing iprec (4.16.24) to flash...

    Configuring iprec.

    ipRec jetzt konfigurieren [ja]:

    0: /media/hdd

    Select the path of the configfiles by number [0] :

    Pfad der Setupdatei [/media/hdd/ipRecSetup.xml]:

    Traceback (most recent call last):

    File "/bin/iprec", line 130, in <module>

    AskForReturn(15)

    File "/bin/iprec", line 59, in __init__

    self.timeout()

    File "/bin/iprec", line 100, in timeout

    self.doc = OpenSetup()

    File "/usr/lib/enigma2/python/Plugins/Extensions/ipRecService/xmltools.py", line 554, in OpenSetup

    document = xml.etree.cElementTree.parse(filename)

    File "<string>", line 56, in parse

    File "<string>", line 35, in parse

    cElementTree.ParseError: not well-formed (invalid token): line 1, column 442

    Traceback (most recent call last):

    File "/bin/iprec", line 132, in <module>

    doc = OpenSetup()

    File "/usr/lib/enigma2/python/Plugins/Extensions/ipRecService/xmltools.py", line 554, in OpenSetup

    document = xml.etree.cElementTree.parse(filename)

    File "<string>", line 56, in parse

    File "<string>", line 35, in parse

    cElementTree.ParseError: not well-formed (invalid token): line 1, column 442

    ************************************************************

    ********** Installation erfolgreich abgeschlossen **********

    ************************************************************


    Hast du eine Idee?


    Gruß Stefan

  • Hallo @stefan0603,


    es ist die /media/hdd/ipRecSetup.xml Datei defekt lösche diese Datei und es wird gehen. Außerem solltest du beim newnigma Image nicht die die Datei Service.py überschreiben. Am besten du löschst auch die /media/hdd/ipRecTimer.xml.


    Ich hoffe das du damit weiter kommst.


    Viel Erfolg


    Aladin